import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\s*)(\\d+)?(\\.\\d+)?(\\s*)(?i:years|year|yrs|y|months|month|m)?(\\s*)(/)?(\\s*)(\\d+)?(\\.\\d+)?(\\s*)(?i:years|year|yrs|y|months|month|m)?(\\s*)(-)?(\\s*)(\\d+)(\\.\\d+)?(\\s*)?(?i:years|year|yrs|y|months|month|m)";
final String string = "1.5Year\n"
+ "1.6years\n"
+ "1.7y\n"
+ "123.2h\n"
+ "23.4CM\n"
+ "2Mw\n"
+ "3wm\n"
+ "01Y\n"
+ "1-2y\n"
+ "39/3-4y\n"
+ "39-34yrs\n"
+ "3.5 - 4.5y\n"
+ "4.6 / 4.5 - 6.5y\n"
+ "9.5-10.5yEAR\n"
+ "7-7.5Y\n"
+ "2m-3y\n"
+ "7 m-7.5 Y\n"
+ "7m - 8.5y\n"
+ "7 m - 8 y\n"
+ "7.5 m -8.5 y\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}