use strict;
my $str = '1.5Year
1.6years
1.7y
123.2h
23.4CM
2Mw
3wm
01Y
1-2y
39/3-4y
39-34yrs
3.5 - 4.5y
4.6 / 4.5 - 6.5y
9.5-10.5yEAR
7-7.5Y
2m-3y
7 m-7.5 Y
7m - 8.5y
7 m - 8 y
7.5 m -8.5 y
';
my $regex = qr~(\s*)(\d+)?(\.\d+)?(\s*)(?i:years|year|yrs|y|months|month|m)?(\s*)(/)?(\s*)(\d+)?(\.\d+)?(\s*)(?i:years|year|yrs|y|months|month|m)?(\s*)(-)?(\s*)(\d+)(\.\d+)?(\s*)?(?i:years|year|yrs|y|months|month|m)~imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}