#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![^@]*\.-)[a-zA-Z][A-Za-z0-9._-]+@[A-Za-z0-9]+\.[A-Za-z]{2,6}\b"
Local $sString = "test@gmail.com" & @CRLF & _
"w-d@sdf.com" & @CRLF & _
"w.d@sdf.com" & @CRLF & _
"w.-d@sdf.com" & @CRLF & _
"w-d@sdfcom"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")