using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![^@]*\.-)[a-zA-Z][A-Za-z0-9._-]+@[A-Za-z0-9]+\.[A-Za-z]{2,6}\b";
string input = @"test@gmail.com
w-d@sdf.com
w.d@sdf.com
w.-d@sdf.com
w-d@sdfcom";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}