import re
regex = re.compile(r"^(?![^@]*\.-)[a-zA-Z][A-Za-z0-9._-]+@[A-Za-z0-9]+\.[A-Za-z]{2,6}\b", flags=re.MULTILINE)
test_str = ("test@gmail.com\n"
"w-d@sdf.com\n"
"w.d@sdf.com\n"
"w.-d@sdf.com\n"
"w-d@sdfcom")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")