re = /^(?![^@]*\.-)[a-zA-Z][A-Za-z0-9._-]+@[A-Za-z0-9]+\.[A-Za-z]{2,6}\b/m
str = 'test@gmail.com
w-d@sdf.com
w.d@sdf.com
w.-d@sdf.com
w-d@sdfcom'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end