package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<a[\s\S]*?href="([^"]+)"[\s\S]*?>`)
var str = `<html>
<head>
...
</head>
<body>
...
<a class="..." href="..." ...>My Text</a>
...
<a href="what is this"
></a>
<a href="can match
across lines" />
</body>
</html>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}