const regex = /<a[\s\S]*?href="([^"]+)"[\s\S]*?>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a[\\s\\S]*?href="([^"]+)"[\\s\\S]*?>', 'gm')
const str = `<html>
<head>
...
</head>
<body>
...
<a class="..." href="..." ...>My Text</a>
...
<a href="what is this"
></a>
<a href="can match
across lines" />
</body>
</html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}