$re = '/<a[\s\S]*?href="([^"]+)"[\s\S]*?>/m';
$str = '<html>
<head>
...
</head>
<body>
...
<a class="..." href="..." ...>My Text</a>
...
<a href="what is this"
></a>
<a href="can match
across lines" />
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);