re = /<a[\s\S]*?href="([^"]+)"[\s\S]*?>/m
str = '<html>
<head>
...
</head>
<body>
...
<a class="..." href="..." ...>My Text</a>
...
<a href="what is this"
></a>
<a href="can match
across lines" />
</body>
</html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end