import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "td class=\".*?stat-last\">.*?<div class=\"statnum\">(.*?)<";
final String string = "<table class=\"profile-stats\">\n"
+ " <tr>\n"
+ " <td class=\"stat\">\n"
+ " <div class=\"statnum\">8</div>\n"
+ " <div class=\"statlabel\"> Tweets </div>\n"
+ " </td>\n"
+ " <td class=\"stat\">\n"
+ " <a href=\"/THEDJMHA/following\">\n"
+ " <div class=\"statnum\">13</div>\n"
+ " <div class=\"statlabel\"> Following </div>\n"
+ " </a>\n"
+ " </td>\n"
+ " <td class=\"stat stat-last\">\n"
+ " <a href=\"/THEDJMHA/followers\">\n"
+ " <div class=\"statnum\">22</div>\n"
+ " <div class=\"statlabel\"> Followers </div>\n"
+ " </a>\n"
+ " </td>\n"
+ " </tr>\n"
+ "</table>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}