// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?s)td class=".*?stat-last">.*?<div class="statnum">(.*?)<"#).unwrap();
let string = "<table class=\"profile-stats\">
<tr>
<td class=\"stat\">
<div class=\"statnum\">8</div>
<div class=\"statlabel\"> Tweets </div>
</td>
<td class=\"stat\">
<a href=\"/THEDJMHA/following\">
<div class=\"statnum\">13</div>
<div class=\"statlabel\"> Following </div>
</a>
</td>
<td class=\"stat stat-last\">
<a href=\"/THEDJMHA/followers\">
<div class=\"statnum\">22</div>
<div class=\"statlabel\"> Followers </div>
</a>
</td>
</tr>
</table>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}