#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((<|<)title(>|>).*?\2\/title\3)"
Local $sString = "<?xml version=\'1.0\'?>" & @CRLF & _
"<document responsecode="200">" & @CRLF & _
" <result count="10" start="0" totalhits="133047950">" & @CRLF & _
" <title>Test</title>" & @CRLF & _
" <from id = "jack">655</from>" & @CRLF & _
" <to>Tsung</to>" & @CRLF & _
" </result>" & @CRLF & _
"</document>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")