import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((<|<)title(>|>).*?\\2\\/title\\3)";
final String string = "<?xml version=\\'1.0\\'?>\n"
+ "<document responsecode=\"200\">\n"
+ " <result count=\"10\" start=\"0\" totalhits=\"133047950\">\n"
+ " <title>Test</title>\n"
+ " <from id = \"jack\">655</from>\n"
+ " <to>Tsung</to>\n"
+ " </result>\n"
+ "</document>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}