import re
regex = re.compile(r"((<|<)title(>|>).*?\2\/title\3)")
test_str = ("<?xml version=\\'1.0\\'?>\n"
"<document responsecode=\"200\">\n"
" <result count=\"10\" start=\"0\" totalhits=\"133047950\">\n"
" <title>Test</title>\n"
" <from id = \"jack\">655</from>\n"
" <to>Tsung</to>\n"
" </result>\n"
"</document>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")