const regex = /((<|<)title(>|>).*?\2\/title\3)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((<|<)title(>|>).*?\\2\\\/title\\3)', '')
const str = `<?xml version=\\'1.0\\'?>
<document responsecode="200">
<result count="10" start="0" totalhits="133047950">
<title>Test</title>
<from id = "jack">655</from>
<to>Tsung</to>
</result>
</document>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}