using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\s+|\\.| ";
string substitution = @" ";
string input = @"fernando mathews \n has the mor diff \r problem \t \* (\n";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}