re = /\\s+|\\.| /m
str = 'fernando mathews \\n has the mor diff \\r problem \\t \\* (\\n'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result