$re = '/\\\\s+|\\\\.| /m';
$str = 'fernando mathews \\n has the mor diff \\r problem \\t \\* (\\n';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;