const regex = /\\s+|\\.| /gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\s+|\\\\.| ', 'gm')
const str = `fernando mathews \\n has the mor diff \\r problem \\t \\* (\\n`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);