import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z]+(?:-[a-zA-Z]+)+";
final String string = "something-something-something/45436534/pd\n"
+ "something-something-something-something/86787097/pd\n"
+ "1135/something-something-something-86789/pp\n"
+ "1125/something-something-something-something-86749/pp";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}