const regex = /[a-zA-Z]+(?:-[a-zA-Z]+)+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-zA-Z]+(?:-[a-zA-Z]+)+', 'g')
const str = `something-something-something/45436534/pd
something-something-something-something/86787097/pd
1135/something-something-something-86789/pp
1125/something-something-something-something-86749/pp`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}