import re
regex = re.compile(r"[a-zA-Z]+(?:-[a-zA-Z]+)+")
test_str = ("something-something-something/45436534/pd\n"
"something-something-something-something/86787097/pd\n"
"1135/something-something-something-86789/pp\n"
"1125/something-something-something-something-86749/pp")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")