re = /[a-zA-Z]+(?:-[a-zA-Z]+)+/
str = 'something-something-something/45436534/pd
something-something-something-something/86787097/pd
1135/something-something-something-86789/pp
1125/something-something-something-something-86749/pp'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end