const regex = /^(?=[a-zA-Z0-9]{7,})(.*?([a-zA-Z0-9]).*?(?!\2)([a-zA-Z0-9]).*?(?!\2|\3)([a-zA-Z0-9]).*?(?!\2|\3|\4)([a-zA-Z0-9]).*?(?!\2|\3|\4|\5)([a-zA-Z0-9]).*?){1,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=[a-zA-Z0-9]{7,})(.*?([a-zA-Z0-9]).*?(?!\\2)([a-zA-Z0-9]).*?(?!\\2|\\3)([a-zA-Z0-9]).*?(?!\\2|\\3|\\4)([a-zA-Z0-9]).*?(?!\\2|\\3|\\4|\\5)([a-zA-Z0-9]).*?){1,}$', 'gm')
const str = `aaaaa
aaaaaaa
abcde
abcdefg
abdcdeseefgff`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}