$re = '/^(?=[a-zA-Z0-9]{7,})(.*?([a-zA-Z0-9]).*?(?!\2)([a-zA-Z0-9]).*?(?!\2|\3)([a-zA-Z0-9]).*?(?!\2|\3|\4)([a-zA-Z0-9]).*?(?!\2|\3|\4|\5)([a-zA-Z0-9]).*?){1,}$/m';
$str = 'aaaaa
aaaaaaa
abcde
abcdefg
abdcdeseefgff';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);