re = /^(?=[a-zA-Z0-9]{7,})(.*?([a-zA-Z0-9]).*?(?!\2)([a-zA-Z0-9]).*?(?!\2|\3)([a-zA-Z0-9]).*?(?!\2|\3|\4)([a-zA-Z0-9]).*?(?!\2|\3|\4|\5)([a-zA-Z0-9]).*?){1,}$/m
str = 'aaaaa
aaaaaaa
abcde
abcdefg
abdcdeseefgff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end