import re
regex = re.compile(r"^(?=[a-zA-Z0-9]{7,})(.*?([a-zA-Z0-9]).*?(?!\2)([a-zA-Z0-9]).*?(?!\2|\3)([a-zA-Z0-9]).*?(?!\2|\3|\4)([a-zA-Z0-9]).*?(?!\2|\3|\4|\5)([a-zA-Z0-9]).*?){1,}$", flags=re.MULTILINE)
test_str = ("aaaaa\n"
"aaaaaaa\n"
"abcde\n"
"abcdefg\n"
"abdcdeseefgff")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")