#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((?:[A-Z]{2}\.[0-9]{1,2})|(?:([0-9]{4}\.[0-9]{1,2})))"
Local $sString = "8920.17 or 8477.1 or 1699.22" & @CRLF & _
"" & @CRLF & _
"DT.3 or SV.32 or TF.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")