import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:[A-Z]{2}\\.[0-9]{1,2})|(?:([0-9]{4}\\.[0-9]{1,2})))";
final String string = "8920.17 or 8477.1 or 1699.22\n\n"
+ "DT.3 or SV.32 or TF.1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}