$re = '/((?:[A-Z]{2}\.[0-9]{1,2})|(?:([0-9]{4}\.[0-9]{1,2})))/';
$str = '8920.17 or 8477.1 or 1699.22
DT.3 or SV.32 or TF.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);