// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:[A-Z]{2}\.[0-9]{1,2})|(?:([0-9]{4}\.[0-9]{1,2})))").unwrap();
let string = "8920.17 or 8477.1 or 1699.22
DT.3 or SV.32 or TF.1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}