import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)((?:<p>.*?<\\/p>\\s*){3})";
final String string = "<p>If you wanna improve yer German, don't try to read Heine or some elevated crap... watch old episodes of [callout]Tatort or Bukow & Konig[/callout].</p>\n"
+ "<p>If I were teaching a music appreciation I wouldn't teach Beethoven. I'd teach Stamitz and average composers.</p>\n"
+ "<p>And here is a 3rd paragraph.</p>\n"
+ "<p>And here is a 4th paragraph.</p>";
final String subst = "$1<blockquote class=\"pullquote\">Tatort or Bukow & Konig</blockquote>\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}