$re = '/(?s)((?:<p>.*?<\/p>\s*){3})/';
$str = '<p>If you wanna improve yer German, don\'t try to read Heine or some elevated crap... watch old episodes of [callout]Tatort or Bukow & Konig[/callout].</p>
<p>If I were teaching a music appreciation I wouldn\'t teach Beethoven. I\'d teach Stamitz and average composers.</p>
<p>And here is a 3rd paragraph.</p>
<p>And here is a 4th paragraph.</p>';
$subst = "$1<blockquote class=\"pullquote\">Tatort or Bukow & Konig</blockquote>\n";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;