use strict;
my $str = '<p>If you wanna improve yer German, don\'t try to read Heine or some elevated crap... watch old episodes of [callout]Tatort or Bukow & Konig[/callout].</p>
<p>If I were teaching a music appreciation I wouldn\'t teach Beethoven. I\'d teach Stamitz and average composers.</p>
<p>And here is a 3rd paragraph.</p>
<p>And here is a 4th paragraph.</p>';
my $regex = qr/(?s)((?:<p>.*?<\/p>\s*){3})/p;
my $subst = '$1<blockquote class="pullquote">Tatort or Bukow & Konig</blockquote>\\n';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";