using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+(?:\.\d+)?[km]?)\W*Comments\b";
string input = @"A | B | C | D
--------------------------------------------------------------------------------
1 | 10.7k Likes, 1.7k Comments - @kristiannairn on Instagram... | |
2 | 4219 Likes, 176 Comments - @djiglobal on Instagram... | |
3 | 1.1m Likes, 209k Comments - @kristiannairn on Instagram... | |";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}