// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+(?:\.\d+)?[km]?)\W*Comments\b").unwrap();
let string = "A | B | C | D
--------------------------------------------------------------------------------
1 | 10.7k Likes, 1.7k Comments - @kristiannairn on Instagram... | |
2 | 4219 Likes, 176 Comments - @djiglobal on Instagram... | |
3 | 1.1m Likes, 209k Comments - @kristiannairn on Instagram... | |";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}