$re = '/(\d+(?:\.\d+)?[km]?)\W*Comments\b/m';
$str = 'A | B | C | D
--------------------------------------------------------------------------------
1 | 10.7k Likes, 1.7k Comments - @kristiannairn on Instagram... | |
2 | 4219 Likes, 176 Comments - @djiglobal on Instagram... | |
3 | 1.1m Likes, 209k Comments - @kristiannairn on Instagram... | |';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);