re = /(\d+(?:\.\d+)?[km]?)\W*Comments\b/m
str = 'A | B | C | D
--------------------------------------------------------------------------------
1 | 10.7k Likes, 1.7k Comments - @kristiannairn on Instagram... | |
2 | 4219 Likes, 176 Comments - @djiglobal on Instagram... | |
3 | 1.1m Likes, 209k Comments - @kristiannairn on Instagram... | |'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end