using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\p{Lu}\p{L}+(?:[\s,.'-]\p{L}+)?$";
string input = @"Афанасий
Łukasz
bob
афанасий
łukasz";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}