$re = '/^\p{Lu}\p{L}+(?:[\s,.\'-]\p{L}+)?$/m';
$str = 'Афанасий
Łukasz
bob
афанасий
łukasz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);