package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\p{Lu}\p{L}+(?:[\s,.'-]\p{L}+)?$`)
var str = `Афанасий
Łukasz
bob
афанасий
łukasz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}