re = /^\p{Lu}\p{L}+(?:[\s,.'-]\p{L}+)?$/m
str = 'Афанасий
Łukasz
bob
афанасий
łukasz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end