#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<forename>.+?)\s(?<surname>\w+)\nBirth\n(?:(?<birth_day>(\d{1,2}|unknown))\s(?<birth_month>\w{3})\s(?<birth_year>\d{4})|\bunknown\b)\n(?<birth_location>.+?\n)?Death\n(?:(?<death_day>(\d{1,2}|unknown))\s(?<death_month>\w{3})\s(?<death_year>\d{4})(?:\s*\(aged\s*(?<age>\d+)\))?|unknown)\n(?<death_location>.+?)\nBurial\n(?<cemetery_name>.+?)\n(?<cemetery_location>.+?)\n(?:Show MapGPS-Latitude:\s*(?<latitude>-?\d+\.\d+),\s*Longitude:\s*(?<longitude>-?\d+\.\d+))?\n?(?:Plot\n(?<plot>.+?)\n?)?Memorial ID\n(?<memorial_id>\d+)"
Local $sString = "Frederick Clarke" & @CRLF & _
"Birth" & @CRLF & _
"6 Feb 1871" & @CRLF & _
"Death" & @CRLF & _
"7 Nov 1952 (aged 81)" & @CRLF & _
"Sheffield" & @CRLF & _
"Burial" & @CRLF & _
"Crookes Cemetery" & @CRLF & _
"Sheffield, Metropolitan Borough of Sheffield, South Yorkshire, England" & @CRLF & _
"Show MapGPS-Latitude: 53.384024, Longitude: -1.515043" & @CRLF & _
"Plot" & @CRLF & _
"MM 7848" & @CRLF & _
"Memorial ID" & @CRLF & _
"237065233"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")