import re
regex = re.compile(r"^(?<forename>.+?)\s(?<surname>\w+)\nBirth\n(?:(?<birth_day>(\d{1,2}|unknown))\s(?<birth_month>\w{3})\s(?<birth_year>\d{4})|\bunknown\b)\n(?<birth_location>.+?\n)?Death\n(?:(?<death_day>(\d{1,2}|unknown))\s(?<death_month>\w{3})\s(?<death_year>\d{4})(?:\s*\(aged\s*(?<age>\d+)\))?|unknown)\n(?<death_location>.+?)\nBurial\n(?<cemetery_name>.+?)\n(?<cemetery_location>.+?)\n(?:Show MapGPS-Latitude:\s*(?<latitude>-?\d+\.\d+),\s*Longitude:\s*(?<longitude>-?\d+\.\d+))?\n?(?:Plot\n(?<plot>.+?)\n?)?Memorial ID\n(?<memorial_id>\d+)", flags=re.MULTILINE)
test_str = ("Frederick Clarke\n"
"Birth\n"
"6 Feb 1871\n"
"Death\n"
"7 Nov 1952 (aged 81)\n"
"Sheffield\n"
"Burial\n"
"Crookes Cemetery\n"
"Sheffield, Metropolitan Borough of Sheffield, South Yorkshire, England\n"
"Show MapGPS-Latitude: 53.384024, Longitude: -1.515043\n"
"Plot\n"
"MM 7848\n"
"Memorial ID\n"
"237065233")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")