const regex = /^(?<forename>.+?)\s(?<surname>\w+)\nBirth\n(?:(?<birth_day>(\d{1,2}|unknown))\s(?<birth_month>\w{3})\s(?<birth_year>\d{4})|\bunknown\b)\n(?<birth_location>.+?\n)?Death\n(?:(?<death_day>(\d{1,2}|unknown))\s(?<death_month>\w{3})\s(?<death_year>\d{4})(?:\s*\(aged\s*(?<age>\d+)\))?|unknown)\n(?<death_location>.+?)\nBurial\n(?<cemetery_name>.+?)\n(?<cemetery_location>.+?)\n(?:Show MapGPS-Latitude:\s*(?<latitude>-?\d+\.\d+),\s*Longitude:\s*(?<longitude>-?\d+\.\d+))?\n?(?:Plot\n(?<plot>.+?)\n?)?Memorial ID\n(?<memorial_id>\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<forename>.+?)\\s(?<surname>\\w+)\\nBirth\\n(?:(?<birth_day>(\\d{1,2}|unknown))\\s(?<birth_month>\\w{3})\\s(?<birth_year>\\d{4})|\\bunknown\\b)\\n(?<birth_location>.+?\\n)?Death\\n(?:(?<death_day>(\\d{1,2}|unknown))\\s(?<death_month>\\w{3})\\s(?<death_year>\\d{4})(?:\\s*\\(aged\\s*(?<age>\\d+)\\))?|unknown)\\n(?<death_location>.+?)\\nBurial\\n(?<cemetery_name>.+?)\\n(?<cemetery_location>.+?)\\n(?:Show MapGPS-Latitude:\\s*(?<latitude>-?\\d+\\.\\d+),\\s*Longitude:\\s*(?<longitude>-?\\d+\\.\\d+))?\\n?(?:Plot\\n(?<plot>.+?)\\n?)?Memorial ID\\n(?<memorial_id>\\d+)', 'gm')
const str = `Frederick Clarke
Birth
6 Feb 1871
Death
7 Nov 1952 (aged 81)
Sheffield
Burial
Crookes Cemetery
Sheffield, Metropolitan Borough of Sheffield, South Yorkshire, England
Show MapGPS-Latitude: 53.384024, Longitude: -1.515043
Plot
MM 7848
Memorial ID
237065233`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}