#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?!.*([wdhml]).*\1)\d*\.?\d+[wdhml](?: \d*\.?\d+[wdhml])*$"
Local $sString = "1w 1d" & @CRLF & _
"1w 1h 1m" & @CRLF & _
"1d 1h 1m" & @CRLF & _
"1h 1m" & @CRLF & _
"1w 1m" & @CRLF & _
"1w" & @CRLF & _
"1w 1w" & @CRLF & _
"1w1w" & @CRLF & _
"1.5w .5d" & @CRLF & _
".5m" & @CRLF & _
"5m"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")