const regex = /^(?!.*([wdhml]).*\1)\d*\.?\d+[wdhml](?: \d*\.?\d+[wdhml])*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*([wdhml]).*\\1)\\d*\\.?\\d+[wdhml](?: \\d*\\.?\\d+[wdhml])*$', 'gmi')
const str = `1w 1d
1w 1h 1m
1d 1h 1m
1h 1m
1w 1m
1w
1w 1w
1w1w
1.5w .5d
.5m
5m`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}