import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*([wdhml]).*\\1)\\d*\\.?\\d+[wdhml](?: \\d*\\.?\\d+[wdhml])*$";
final String string = "1w 1d\n"
+ "1w 1h 1m\n"
+ "1d 1h 1m\n"
+ "1h 1m\n"
+ "1w 1m\n"
+ "1w\n"
+ "1w 1w\n"
+ "1w1w\n"
+ "1.5w .5d\n"
+ ".5m\n"
+ "5m";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}