package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^.]*(?:(?:\.[^\.]*){0,1})$`)
var str = `lo.cat.tion
location
loca.tion
loca_caca
loca.cas.cas.acs
asd.asd.asas.asd.asd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}